Support Phone System - Difficulties receiving inbound phone calls

Incident Report for SimpleNexus.com

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:27 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 15:03 MDT

Identified

Our Support phone lines are currently experiencing difficulties receiving calls. During this time, it is encouraged to use the nCino Mortgage Help Center, found at https://mortgagehelp.ncino.com to submit a ticket inquiry.

We will continue to work with our third party provider on a resolution. Updates will be shared as they become available.
Posted Jun 12, 2025 - 12:49 MDT
This incident affected: Support (Support Phones).