Partners can not be created via the Mobile app
Incident Report for SimpleNexus.com
Resolved
This has been fixed Partners can be created and edited from the mobile apps again. Thank you for your patience
Posted Apr 02, 2020 - 17:39 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2020 - 17:09 MDT
Investigating
We are aware and working on a fix for this issue
Posted Apr 01, 2020 - 17:08 MDT