Login Errors
Incident Report for SimpleNexus.com
Resolved
This incident has been resolved.
Posted Mar 05, 2020 - 21:42 UTC
Monitoring
The fix has been deployed and we are reporting that the login page is working again.
Posted Mar 05, 2020 - 18:37 UTC
Investigating
We are currently working on problems with the login page.
Posted Mar 05, 2020 - 18:25 UTC
This incident affected: Login.