Support Offline
Incident Report for SimpleNexus.com
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 14:13 UTC
Update
Our internet and phones are operational again and Support is working thru the tickets submitted this morning. Thank you for being patience.
Posted Oct 23, 2019 - 14:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 23, 2019 - 13:14 UTC
Identified
The internet and Support phones are currently not functional. We are working to restore these services and will provide updates as they are available.
Posted Oct 23, 2019 - 13:11 UTC
This incident affected: Support (Support Phones, Support Emails).